srkp.net
当前位置:首页 >> jDk1.8 向下兼容 >>

jDk1.8 向下兼容

方法/步骤 使用maven的时候,默认会使用1.5版本的JDK,并且也是编译成1.5的,我的电脑里面用的JDK是1.7的,1.8也出来了,没理由还用1.5的吧!所以我手动改成了1.7,郁闷的是,每次 maven-update project 的时候,又变成1.5的了 查阅了相关资料后...

不行,是向下兼容的,即jre1.5能运行的,jre1.8能运行,反之不一定能行,如你使用了1.8的特性,在1.5里面肯定是运行不了的,如果没有使用特性,可能可以兼容

支持,看看你的类是不是在1.7的java环境编译的,还有看看你的tomcat使用的jre是不是1.8的,是不是装了多个不同版本的jre,可能是tomcat引入的jre和jdk的不一样

在JDK1.7的新特性方面主要有下面几方面的增强: 1.jdk7语法上 1.1二进制变量的表示,支持将整数类型用二进制来表示,用0b开头。 1.2 Switch语句支持string类型 1.3 Try-with-resource语句 注意:实现java.lang.AutoCloseable接口的资源都可以放到...

网站首页 | 网站地图
All rights reserved Powered by www.srkp.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com