srkp.net
当前位置:首页 >> jquEry%1.9.1.js AjAx调用了但不返回值啊 >>

jquEry%1.9.1.js AjAx调用了但不返回值啊

把你代码发出来看看,首先你确保你ajax代码在发出请求之前没有出错,请求是正常发出的,这个你可以通过浏览器控制台中network中监控发出的请求 然后你确保你ajax的回调函数中写了对成功success的处理和对出错error的处理函数,然后检查者两个对...

jQuery.ajax({ type: 'post', //async:false, url: 'ajaxgetlogo.do', dataType: 'text', success: function(result){ alert(result); }, error: function(date){ alert(12345); } });把这行去掉

jQuery.ajax({ type: 'post', //async:false, url: 'ajaxgetlogo.do', dataType: 'text', success: function(result){ alert(result); }, error: function(date){ alert(12345); } });把这行去掉

我刚好今天遇到这个问题,没有跨域,chrome可以,但是ie就是报错。检查了大半天,终于发现问题所在了。 这是jquery1.9的bug(具体什么bug没有继续研究)。 你把引用的jquery库换成jquery-1.11.1.js 就没问题了。 另外,还有种解决办法就是,把涉...

这个我就不太明白了 你为什么要引进2个版本的JQ 除非你去修改源代码 否则大概是无解的 建议你只选择用一种(当然最好选用高版本1.9.1) 引用多了也无非是增加客户端网络负担吧

返回数据代码如下: 如果在php里有echo的值的话,可以用AJAX来接收: 有多个输出的话,是不可能指定输出的需要把想要输出的内容放到一个数组中,然后json_encode一下,在到js里循环,找到自己想要的值比如://需要输出的内容echo 'aaa'; echo 'b...

你好!! jquery-1.9.0.min.js 这个文件是jQuery的框架库,版本为1.9.0,min表示它是被压缩过的。 它是对javascript的一个轻量级的封装,相当于一个编译器,将jQuery写法的语句,转为javascript进行执行。

jquery库, jQuery最初就是把javascript封装起来,方便调用。

jquery-1.9.0.js是可以调试的版本,包含注释,没有经过压缩,相对较大,在开发环境中使用; jquery-1.9.0.min.js经过压缩处理,尺寸小,下载的尺寸小,加载的时间短,在运行环境中使用。

$.post应该是支持的,看你具体报什么错,应该和版本无关!

网站首页 | 网站地图
All rights reserved Powered by www.srkp.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com